System Requirements

Drupal (and therefore WissKI) needs the typical webstack as a prerequisite.  The Apache HTTP webserver and a MySQL server are recommended.  One of the easiest ways to get these is to get the XAMPP software.  For further documentation of the prerequisites of Drupal please have a look at the drupal installation tutorial.

Currently we recommend the following software for running WissKI:

  • Apache 2.X
  • Mod Rewrite (for clean URL support)
  • MySQL 5.1.X (we experienced some problems with MySQL 5.5 - please stay tuned for updates if you are using MySQL 5.5)
  • PHP Version 5.3.X
  • Drupal 6.X